PEAR

Jump to: navigation, search

Introduction

The goal of this page is to list PEAR packages compulsory to the execution of OpenFlyers starting from version 1.2.

Pear Installer

To install PEAR packages on your local server (Windows) you can follow this manual setting

  • Start go-pear.bat locate in your PHP directory
  • In DOS windows follow the instruction :

- system|local
- If you need type 1 to change your directory
- Agree to update your php.ini with include_path

  • PEAR is now install in your directory PEAR
  • Execute the file PEAR_ENV.reg created in your PHP directory to update your environement
  • Check that you can directly acces to the file pear.bat

- In DOS prompt type

pear install MDB2_Driver_mysqli

or if not stable package release

pear install channel://pear.php.net/ole-0.6.1 (version number can be change)
  • Continue for all package you need.....


OF release 1.2

Pack Release succesfully tried with OpenFlyers
Archive_Tar 1.3.1
Console_Getopt 1.2
Date 1.4.6
Mail 1.1.14
Net_SMTP 1.2.10
Net_Socket 1.0.7
OLE 0.5
PEAR 1.4.11
Spreadsheet_Excel_Writer] 0.9.1
XML_RPC 1.5.1

OF release 1.3

Same as OF release 1.2 and in addition:

Pack Release succesfully tried with OpenFlyers
XML_RPC 1.4.8
WARNING: OF 1.3.3 DOES NOT WORK WITH PEAR::DATE 1.4.6
WARNING: OF 1.3.4 DOES NOT WORK WITH PHP 4

OF release 2

Pack Release succesfully tried with OpenFlyers
Archive_Tar 1.3.3
Cache_Lite 1.7.2
Console_Getopt 1.2.3
Date 1.4.7
HTTP_Request2 0.4.1
MDB2 2.4.1
MDB2_Driver_mysqli 1.4.1
Mail 1.1.14
Math_Stats 0.9.0beta3
Net_SMTP 1.2.10
Net_Socket 1.0.8
Net_URL 0.3.0
OLE 0.5
PEAR 1.9.0
Pager 2.4.4
SQL_Parser] 0.5
Spreadsheet_Excel_Writer] 0.9.1
Structures_Graph] 1.0.3
Text_Wiki] 1.2.0
Text_Wiki_BBCode] 0.0.4
XML_Beautifier] 1.1
XML_Parser] 1.2.8
XML_Query2XML 1.5.0
XML_RPC 1.5.1
XML_RPC2 1.0.2
XML_Util 1.2.1

OF release 2.1

Pack Release succesfully tried with OpenFlyers
Archive_Tar 1.3.3
Cache_Lite 1.7.2
Console_Getopt 1.2.3
Date 1.4.7
HTTP_Request2 0.5.2
MDB2 2.4.1
MDB2_Driver_mysqli 1.4.1
Mail 1.1.14
Math_Stats 0.9.0beta3
Net_SMTP 1.2.10
Net_Socket 1.0.8
Net_URL2 0.3.1
OLE 0.5 compulsory (bug with 0.6 when trying to parse "UPDATE authentication SET activated=0 WHERE id=?")
PEAR 1.9.0
Pager 2.4.4
SQL_Parser 0.5
Spreadsheet_Excel_Writer 0.9.2
Structures_Graph 1.0.3
Text_Wiki 1.2.0
Text_Wiki_BBCode 0.0.4
XML_Beautifier 1.2.0
XML_Parser] 1.2.8
XML_Query2XML 1.5.0
XML_RPC 1.5.1
XML_RPC2 1.0.2
XML_Util 1.2.1
WARNING: OF 2.1 DOES NOT WORK WELL WITH PEAR::SQL_PARSER 0.6